summaryrefslogtreecommitdiff
path: root/emu/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-12-10 19:50:39 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-12-10 19:50:39 +0100
commit1269d11d15f1014b7ac87fc2bb2c76367404e16c (patch)
treed8d4595811b279d2e7d5ccef32f55ba5cbcba585 /emu/CMakeLists.txt
parent84e25eb07749636b48deb802d673f44841c55d91 (diff)
download6502-1269d11d15f1014b7ac87fc2bb2c76367404e16c.tar.gz
6502-1269d11d15f1014b7ac87fc2bb2c76367404e16c.tar.bz2
some more unit testing
Diffstat (limited to 'emu/CMakeLists.txt')
-rw-r--r--emu/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/emu/CMakeLists.txt b/emu/CMakeLists.txt
index 535802a..6e13d00 100644
--- a/emu/CMakeLists.txt
+++ b/emu/CMakeLists.txt
@@ -27,7 +27,6 @@ set(SRC
memory.c
7seg.c
emul.c
- emu.c
)
ADD_GENGETOPT_FILES(SRC options.ggo)
@@ -40,8 +39,11 @@ PKG_SEARCH_MODULE(CHECK REQUIRED check)
include_directories(${SDL2_INCLUDE_DIRS} ${SDL2_INCLUDE_DIRS})
-add_executable(emu ${SRC})
-target_link_libraries(emu ${SDL2_LIBRARIES} ${SDL2_GFX_LIBRARIES})
+add_library(emulib STATIC ${SRC})
+
+add_executable(emu emu.c)
+target_link_libraries(emu ${SDL2_LIBRARIES} ${SDL2_GFX_LIBRARIES} emulib)
enable_testing()
add_subdirectory(tests)
+add_custom_target(report DEPENDS tests/test.html)