summaryrefslogtreecommitdiff
path: root/emu/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-11-27 20:04:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-11-27 20:04:18 +0100
commitf829f6893d94ed52044bf007bc447526c9d5e653 (patch)
treec1c98d8b9240b4507719aa8b78eb3ee03dd64ab5 /emu/CMakeLists.txt
parent3d77f3f5ad41e931117425f58c74f49c9503bf7b (diff)
download6502-f829f6893d94ed52044bf007bc447526c9d5e653.tar.gz
6502-f829f6893d94ed52044bf007bc447526c9d5e653.tar.bz2
emulator uses a bus now in the cpu, ROM, RAM and VIA (7-seg) are devices connected to the bus
Diffstat (limited to 'emu/CMakeLists.txt')
-rw-r--r--emu/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/emu/CMakeLists.txt b/emu/CMakeLists.txt
index e1fe6c9..04b1788 100644
--- a/emu/CMakeLists.txt
+++ b/emu/CMakeLists.txt
@@ -8,7 +8,7 @@ project(emu C)
set( EMU_VERSION 0.0.1 )
-set(CMAKE_C_FLAGS "-g -O0 -std=c99 -Wall -DWITH_GUI")
+set(CMAKE_C_FLAGS "-g -O0 -std=c99 -Wall -DWITH_GUI -D_POSIX_C_SOURCE=200809L")
add_custom_target(distclean
COMMAND make clean
@@ -21,6 +21,8 @@ configure_file( "${PROJECT_SOURCE_DIR}/version.h.in"
"${PROJECT_SOURCE_DIR}/version.h" @ONLY )
set(SRC
+ device.c
+ bus.c
6502.c
memory.c
7seg.c