summaryrefslogtreecommitdiff
path: root/emu/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'emu/tests/CMakeLists.txt')
-rw-r--r--emu/tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/emu/tests/CMakeLists.txt b/emu/tests/CMakeLists.txt
new file mode 100644
index 0000000..5011371
--- /dev/null
+++ b/emu/tests/CMakeLists.txt
@@ -0,0 +1,4 @@
+add_executable(test_cpu_6502 test_cpu_6502.c)
+target_link_libraries(test_cpu_6502 ${CHECK_LIBRARIES} pthread)
+
+add_test(NAME test_cpu_6502 COMMAND test_cpu_6502 WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/tests)