summaryrefslogtreecommitdiff
path: root/3rdParty/captcha/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2015-04-30 21:02:15 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2015-04-30 21:02:15 +0200
commit536cc69836d758ab7d156115ce296a3a25ce8aac (patch)
treeff24e7f4ed01a9343fe73f049defb4b93f201a5a /3rdParty/captcha/CMakeLists.txt
parenta3e26005fe00abe8836ba5dcdd1b9887ae6b1c27 (diff)
parent37dd84ec2145f500dce94fb136bd266b6445ae16 (diff)
downloadaCms-536cc69836d758ab7d156115ce296a3a25ce8aac.tar.gz
aCms-536cc69836d758ab7d156115ce296a3a25ce8aac.tar.bz2
Merge branch 'master' of ssh://git.andreasbaumann.cc/strusCms
Diffstat (limited to '3rdParty/captcha/CMakeLists.txt')
-rw-r--r--3rdParty/captcha/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rdParty/captcha/CMakeLists.txt b/3rdParty/captcha/CMakeLists.txt
new file mode 100644
index 0000000..4e59b19
--- /dev/null
+++ b/3rdParty/captcha/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+set(libcaptcha_source_files
+ captcha.c
+ f.h
+)
+
+set(unfont_source_files
+ unfont.c
+)
+
+if(NOT WIN32)
+ add_definitions("-fPIC")
+endif()
+
+add_custom_command(
+ PRE_BUILD
+ OUTPUT f.h
+ COMMAND ./unfont > f.h
+ DEPENDS unfont
+)
+
+add_executable(unfont ${unfont_source_files})
+
+add_library(captcha STATIC ${libcaptcha_source_files})
+