summaryrefslogtreecommitdiff
path: root/3rdParty/libb64/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdParty/libb64/CMakeLists.txt')
-rw-r--r--3rdParty/libb64/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/3rdParty/libb64/CMakeLists.txt b/3rdParty/libb64/CMakeLists.txt
new file mode 100644
index 0000000..ae4d3a9
--- /dev/null
+++ b/3rdParty/libb64/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+set(libb64_source_files
+ src/cdecode.c
+ src/cencode.c
+)
+
+include_directories(
+ "include"
+)
+
+add_definitions(
+ "-DBUFFERSIZE=4096"
+)
+
+if(NOT WIN32)
+ add_definitions("-fPIC")
+endif()
+
+add_library(b64 STATIC ${libb64_source_files})