summaryrefslogtreecommitdiff
path: root/3rdParty/libquickmail/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdParty/libquickmail/CMakeLists.txt')
-rw-r--r--3rdParty/libquickmail/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/3rdParty/libquickmail/CMakeLists.txt b/3rdParty/libquickmail/CMakeLists.txt
new file mode 100644
index 0000000..c0b8fad
--- /dev/null
+++ b/3rdParty/libquickmail/CMakeLists.txt
@@ -0,0 +1,28 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+set(libquickmail_source_files
+ quickmail.c
+ smtpsocket.c
+)
+
+set(quickmailprog_source_files
+ quickmailprog.c
+)
+
+include_directories(
+ "."
+)
+
+#~ add_definitions(
+ #~ "-DNOCURL"
+#~ )
+
+if(NOT WIN32)
+ add_definitions("-fPIC")
+endif()
+
+add_executable(quickmailprog ${quickmailprog_source_files})
+
+target_link_libraries(quickmailprog quickmail curl)
+
+add_library(quickmail STATIC ${libquickmail_source_files})