summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2c0a2b..858369a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,10 @@ find_program(XGETTEXT xgettext)
find_program(MSGFMT msgfmt)
find_program(MSGMERGE msgmerge)
+if(CMAKE_COMPILER_IS_GNUCXX)
+set( CMAKE_CXX_FLAGS "-std=c++98 -Wall -pedantic -g -Wfatal-errors -Werror -fPIC -O0" )
+endif()
+
set(TEMPLATES
${CMAKE_CURRENT_SOURCE_DIR}/templates/main.tmpl
${CMAKE_CURRENT_SOURCE_DIR}/templates/intro.tmpl