summaryrefslogtreecommitdiff
path: root/adapted/linux-lts510/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'adapted/linux-lts510/PKGBUILD')
-rw-r--r--adapted/linux-lts510/PKGBUILD265
1 files changed, 265 insertions, 0 deletions
diff --git a/adapted/linux-lts510/PKGBUILD b/adapted/linux-lts510/PKGBUILD
new file mode 100644
index 0000000..71ee099
--- /dev/null
+++ b/adapted/linux-lts510/PKGBUILD
@@ -0,0 +1,265 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Jonathon Fernyhough <jonathon+m2x+dev>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgbase=linux-lts510
+pkgver=5.10.176
+pkgrel=2
+pkgdesc='LTS 5.10 Linux'
+url="https://www.kernel.org/"
+arch=(x86_64 pentium4 i686 i486)
+license=(GPL2)
+makedepends=(
+ bc kmod libelf pahole cpio perl tar xz
+ xmlto python-sphinx python-sphinx_rtd_theme python-six graphviz imagemagick
+)
+options=('!strip')
+_srcname=linux-$pkgver
+source=(
+ https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.{xz,sign}
+ config # the main kernel config file
+ 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
+)
+validpgpkeys=(
+ 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+)
+# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
+sha256sums=('ce072c60ba04173e05b2a1de3fefdeba5ac8b28b1958d92d21bdbf9b736ef793'
+ 'SKIP'
+ '83a9abaa95fb30465e630cf44020300c68b44247e6d7933efaf756d10d93d063'
+ '96a72e1652314215da7140956c3abcf495cafd00811eda3cf4ce03ec5f791f1e')
+
+export KBUILD_BUILD_HOST=archlinux
+export KBUILD_BUILD_USER=$pkgbase
+export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
+
+prepare() {
+ cd $_srcname
+
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+ echo "Setting config..."
+ cp ../config .config
+ make olddefconfig
+
+ make -s kernelrelease > version
+ echo "Prepared $pkgbase version $(<version)"
+}
+
+build() {
+ cd $_srcname
+ make all
+ make htmldocs
+}
+
+_package() {
+ pkgdesc="The $pkgdesc kernel and modules"
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+
+ cd $_srcname
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
+ echo "Installing boot image..."
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+
+ # remove build and source links
+ rm "$modulesdir"/{source,build}
+}
+
+_package-headers() {
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+
+ cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
+
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+
+ # add xfs and shmem for aufs building
+ mkdir -p "$builddir"/{fs/xfs,mm}
+
+ echo "Installing headers..."
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+
+ # http://bugs.archlinux.org/task/13146
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+
+ # http://bugs.archlinux.org/task/20402
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+
+ echo "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+
+ echo "Removing unneeded architectures..."
+ local arch
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
+ done
+
+ echo "Removing documentation..."
+ rm -r "$builddir/Documentation"
+
+ echo "Removing broken symlinks..."
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+
+ echo "Removing loose objects..."
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ echo "Stripping build tools..."
+ local file
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
+ application/x-sharedlib\;*) # Libraries (.so)
+ strip -v $STRIP_SHARED "$file" ;;
+ application/x-archive\;*) # Libraries (.a)
+ strip -v $STRIP_STATIC "$file" ;;
+ application/x-executable\;*) # Binaries
+ strip -v $STRIP_BINARIES "$file" ;;
+ application/x-pie-executable\;*) # Relocatable binaries
+ strip -v $STRIP_SHARED "$file" ;;
+ esac
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
+}
+
+_package-docs() {
+ pkgdesc="Documentation for the $pkgdesc kernel"
+
+ cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing documentation..."
+ local src dst
+ while read -rd '' src; do
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/share/doc"
+ ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
+
+# vim:set ts=8 sts=2 sw=2 et:
+
+eval "$(
+ declare -f package_linux-lts510-headers | \
+ sed '
+ \,/tools/objtool" ,d
+ \,arch/x86/Makefile,a install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile_32.cpu
+ '
+)"
+
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" -o "${CARCH}" = "pentium4" ]; then
+ source_pentium4=('config.pentium4')
+ source_i686=('config.i686')
+ source_i486=('config.i486')
+ # fail if upstream's .config changes
+ for ((i=0; i<${#sha256sums[@]}; i++)); do
+ if [ "${sha256sums[${i}]}" = '83a9abaa95fb30465e630cf44020300c68b44247e6d7933efaf756d10d93d063' ]; then
+ sha256sums_pentium4=('8313173f53a225df263e4c3cf7be779c26a371fb31b44f9a61a977fc786a4805')
+ sha256sums_i686=('9c9733b04e28e090e46c33458fb6172c221332a7547f28bbf7883c6102802fe0')
+ sha256sums_i486=('f39dc3074b405a469b35e8499b3937f68e49d3786a1e3e0c48cfe77cd2f79383')
+ fi
+ done
+
+ # copy architecture specific config file, not default 'config'
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s,\.\./config,../config.$CARCH,
+ '
+ )"
+
+ # patch architecture when copying the kernel Makefile
+ eval "$(
+ declare -f package_linux510-headers | \
+ sed '
+ \,/tools/objtool" ,d
+ \,arch/x86/Makefile, {
+ a \
+ install -t "${builddir}/arch/x86" -m644 arch/x86/Makefile_32.cpu
+ }
+ '
+ )"
+
+ # avoid using zstd compression in ultra mode (exhausts virtual memory)
+ source+=('no-ultra-zstd.patch')
+ sha256sums+=('3997ce6033fdf950a9960f1db720b38c47b1a2e06ab75fc6712c154f596e7c47')
+ # upstream prepare() does already do the *.patch patching
+
+ # temporarily disabled documentation due to sphinx_rtd_theme (FS32#163)
+ pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" | \
+ grep -v '^\$pkgbase-docs'
+ )
+ )
+ eval "$(
+ declare -f build | \
+ sed '
+ s/\bhtmldocs\b//
+ '
+ )"
+ makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python-six/})
+ makedepends=(${makedepends[@]//graphviz/})
+ makedepends=(${makedepends[@]//imagemagick/})
+fi