summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2015-08-08 16:57:16 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2015-08-08 16:57:16 +0200
commit02fc9c6d5e5dbc0b8e8502e3b86e1fbd67f491d7 (patch)
treee18d7b37d021f64bfc68bf491ed6437a63e4e6f7 /CMakeLists.txt
parentd42be19fd2f8f93b045c8e0642a50413f8e36223 (diff)
downloadcssh-02fc9c6d5e5dbc0b8e8502e3b86e1fbd67f491d7.tar.gz
cssh-02fc9c6d5e5dbc0b8e8502e3b86e1fbd67f491d7.tar.bz2
minimal frame
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89fa63c..ee3367f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,11 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
project(cssh C)
+set( CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -Wfatal-errors -Werror -fPIC -O0" )
+
+add_subdirectory(src)
+
add_custom_target(distclean
COMMAND git clean -d -f -x
)