summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-04-27 10:07:36 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2017-04-27 10:07:36 +0200
commit658a53c6aee000b8846695132e22bb914e6cf7dc (patch)
treeaedbcef11dff013190f3ac8dadfb1d71e990c594 /src/CMakeLists.txt
parentdc1fb59fd30e76571c9151900a84ac3c814ee167 (diff)
downloadcssh-658a53c6aee000b8846695132e22bb914e6cf7dc.tar.gz
cssh-658a53c6aee000b8846695132e22bb914e6cf7dc.tar.bz2
fixed probing for libssh (especially fixes OSX build issues)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d61aec9..6404868 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
include_directories(
- ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${libssh_INCLUDE_PATH}
"${PROJECT_BINARY_DIR}/src"
"${PROJECT_SOURCE_DIR}/3rdParty/linenoise"
)
@@ -16,6 +16,6 @@ ADD_GENGETOPT_FILES(SRC options.ggo)
add_executable(cssh ${SRC})
-target_link_libraries(cssh ssh curses linenoise)
+target_link_libraries(cssh ${libssh_LIBRARY} curses linenoise)
install( TARGETS cssh RUNTIME DESTINATION bin )