summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-02-02 19:30:27 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2017-02-02 19:30:27 +0100
commita1cace00d663ca9e2c38182ccd490c5a819b31aa (patch)
tree9e062cfb82631ceffca6ef62ab4602f73b33d66d /src/CMakeLists.txt
parent8a0085b05204cce0069aef9e206b81c9ee11dc83 (diff)
downloadcssh-a1cace00d663ca9e2c38182ccd490c5a819b31aa.tar.gz
cssh-a1cace00d663ca9e2c38182ccd490c5a819b31aa.tar.bz2
implemented interactive shell mode with linenoise
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 793c742..e4a23e6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,4 +1,9 @@
-include_directories(${LIBSSH_PUBLIC_INCLUDE_DIRS})
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+include_directories(
+ ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ "${PROJECT_SOURCE_DIR}/3rdParty/linenoise"
+)
set(SRC
cssh.c
@@ -10,4 +15,4 @@ ADD_GENGETOPT_FILES(SRC options.ggo)
add_executable(cssh ${SRC})
-target_link_libraries(cssh ssh curses)
+target_link_libraries(cssh ssh curses linenoise)