summaryrefslogtreecommitdiff
path: root/emu/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-12-10 19:50:39 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2020-12-10 19:50:39 +0100
commit1269d11d15f1014b7ac87fc2bb2c76367404e16c (patch)
treed8d4595811b279d2e7d5ccef32f55ba5cbcba585 /emu/tests/CMakeLists.txt
parent84e25eb07749636b48deb802d673f44841c55d91 (diff)
download6502-1269d11d15f1014b7ac87fc2bb2c76367404e16c.tar.gz
6502-1269d11d15f1014b7ac87fc2bb2c76367404e16c.tar.bz2
some more unit testing
Diffstat (limited to 'emu/tests/CMakeLists.txt')
-rw-r--r--emu/tests/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/emu/tests/CMakeLists.txt b/emu/tests/CMakeLists.txt
index 5011371..88d2e97 100644
--- a/emu/tests/CMakeLists.txt
+++ b/emu/tests/CMakeLists.txt
@@ -1,4 +1,8 @@
add_executable(test_cpu_6502 test_cpu_6502.c)
-target_link_libraries(test_cpu_6502 ${CHECK_LIBRARIES} pthread)
+target_link_libraries(test_cpu_6502 ${CHECK_LIBRARIES} pthread emulib)
+
+include_directories(${CMAKE_SOURCE_DIR})
add_test(NAME test_cpu_6502 COMMAND test_cpu_6502 WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/tests)
+
+add_custom_target(test.html DEPENDS test.xml COMMAND xsltproc check_unittest.xslt test.xml > test.html DEPENDS test.xml)