summaryrefslogtreecommitdiff
path: root/emu/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'emu/tests/CMakeLists.txt')
-rw-r--r--emu/tests/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/emu/tests/CMakeLists.txt b/emu/tests/CMakeLists.txt
index 5011371..88d2e97 100644
--- a/emu/tests/CMakeLists.txt
+++ b/emu/tests/CMakeLists.txt
@@ -1,4 +1,8 @@
add_executable(test_cpu_6502 test_cpu_6502.c)
-target_link_libraries(test_cpu_6502 ${CHECK_LIBRARIES} pthread)
+target_link_libraries(test_cpu_6502 ${CHECK_LIBRARIES} pthread emulib)
+
+include_directories(${CMAKE_SOURCE_DIR})
add_test(NAME test_cpu_6502 COMMAND test_cpu_6502 WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/tests)
+
+add_custom_target(test.html DEPENDS test.xml COMMAND xsltproc check_unittest.xslt test.xml > test.html DEPENDS test.xml)