summaryrefslogtreecommitdiff
path: root/3rdParty/captcha/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2015-04-29 18:58:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2015-04-29 18:58:07 +0200
commitcb69299b9d59db0888e942025ae4915c6f32d066 (patch)
treefcb85301442a9eda1ed9d60a8ba52d8c60f11114 /3rdParty/captcha/CMakeLists.txt
parentfa132310bf61c115907e5c237333207f308b1de4 (diff)
downloadaCms-cb69299b9d59db0888e942025ae4915c6f32d066.tar.gz
aCms-cb69299b9d59db0888e942025ae4915c6f32d066.tar.bz2
added libquickmail and email registration
Diffstat (limited to '3rdParty/captcha/CMakeLists.txt')
-rw-r--r--3rdParty/captcha/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rdParty/captcha/CMakeLists.txt b/3rdParty/captcha/CMakeLists.txt
new file mode 100644
index 0000000..4e59b19
--- /dev/null
+++ b/3rdParty/captcha/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+set(libcaptcha_source_files
+ captcha.c
+ f.h
+)
+
+set(unfont_source_files
+ unfont.c
+)
+
+if(NOT WIN32)
+ add_definitions("-fPIC")
+endif()
+
+add_custom_command(
+ PRE_BUILD
+ OUTPUT f.h
+ COMMAND ./unfont > f.h
+ DEPENDS unfont
+)
+
+add_executable(unfont ${unfont_source_files})
+
+add_library(captcha STATIC ${libcaptcha_source_files})
+