summaryrefslogtreecommitdiff
path: root/3rdParty/captcha/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdParty/captcha/CMakeLists.txt')
-rw-r--r--3rdParty/captcha/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rdParty/captcha/CMakeLists.txt b/3rdParty/captcha/CMakeLists.txt
new file mode 100644
index 0000000..4e59b19
--- /dev/null
+++ b/3rdParty/captcha/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 2.6 FATAL_ERROR)
+
+set(libcaptcha_source_files
+ captcha.c
+ f.h
+)
+
+set(unfont_source_files
+ unfont.c
+)
+
+if(NOT WIN32)
+ add_definitions("-fPIC")
+endif()
+
+add_custom_command(
+ PRE_BUILD
+ OUTPUT f.h
+ COMMAND ./unfont > f.h
+ DEPENDS unfont
+)
+
+add_executable(unfont ${unfont_source_files})
+
+add_library(captcha STATIC ${libcaptcha_source_files})
+